The PaperSnow site works best with a modern computer and web browser.

Suggested minimum requirements are a 1Ghz or faster processor, and the 1.4 version or higher Java web browser plugin. It is recommended to only view one picture at a time for most computers. Flickering graphics may mean either the computer is too slow, there are too many other items open on the desktop, or there may be some other problem.

Get Powered

Java Runtime Environment

PaperSnow uses the Java plug-in from Sun Microsystems - click on the image on the left to get the latest version.

Support CC - 2007

Creative Commons

Many of the pictures on the site are used under a Creative Commons license. This gives content producers flexibility in specifying how their work is used. Where a picture is used with this license, click on the icon underneath it to see the usage terms.